新的PHP选择器接口 - 现在in Beta

 

b2ap3_large_php-selector-production-1

我们在LVE Manager V.6.0.6-1和其他新功能中为CPANEL引入了一种改进的PHP选择器接口。我将在下面展示它们。

如何通过ClowLinux PHP选择器管理CPANEL MultiPHP Manager管理到管理

CPanel有自己的MultiPHP管理器来管理域的PHP版本。要移动域通过MultiPHP Manager管理到由CloudLinux PHP选择器管理,需要满足特定条件:

  1. 应安装以下组件:
  2. 系统PHP版本不是 ALT-PHP. (它应该是 EA-PHP.)
    你可以检查一下 CPANEL管理界面→MultiPHP Manager→PHP版本
    MultiphpManager.
  3. 选择适用的PHP处理程序,用于PHP版本,它是系统版本。 PHP选择器是 兼容的 具有以下技术: suphp,mod_fcgid,cgi(suexec),litespeed。您可以检查使用的处理程序 CPANEL管理界面→MultiPHP Manager→PHP处理程序

    PHP.处理程序
  4. 域没有 PHP.-FPM. 启用。你可以检查是否 PHP.-FPM. 已启用\已禁用 CPANEL管理接口→MultiPHP Manager→PHP版本→ 滚动到 设置每个域的PHP版本
  5. 域的PHP版本等于系统PHP版本。您可以检查PHP版本 CPANEL管理接口→MultiPHP Manager→PHP版本→ 滚动到 设置每个域的PHP版本
  6. CloudLinux PHP选择器中的PHP版本不等于本机PHP版本。你可以检查一下 CPANEL用户界面→ 选择 PHP版本→ 选择不等于本土的PHP版本点击 Set as current.

仪表板通知 

我们处理最受欢迎的问题并向您添加他们的通知 仪表板 (admin interface).

仪表板Notifications.

 

诊断工具

在这一点 选择器 选项卡(管理员接口)我们有改进了我们的诊断工具。

诊断工具

此工具可以处理哪些问题:

  1. mod_suexec.. is not installed
  2. ALT-PHP. 版本是系统默认版本
  3. 有些用户域有 PHP.-FPM. 启用或PHP版本与系统默认版本不同

如果问题已修复,您可以刷新诊断。

PHP.选择器选项卡(管理界面)

在里面 选择器 选项卡,我们添加了一个子标签 Domains 所有 用户域 pairs.

domainssubtab1.

当管理员点击时 使用PHP选择器, PHP.-FPM. 已被设置为OFF,PHP版本设置为系统默认版本。用户的域获取PHP选择器的用户界面中选择的PHP版本。

PHP.选择器选项卡(最终用户界面)

域名 选项卡也可在PHP选择器最终用户界面中使用。

domainsui1.

 

如果管理员已成功执行步骤一到四个 如何切换 部分,那么最终用户可以配置域以使用CloudLinux PHP选择器。

最终用户应该执行以下操作:

  1. 点击 使用PHP选择器

    umerphpselector1-1

  2. 在PHP选择器中设置版本

    setversion.

如果 PHP.-FPM. 已为域启用(请参阅第四步 如何切换 部分)唯一的管理员可以将其设置为 禁用.

管理员可以禁用 我的领域 子标签中 管理员界面→LVE Manager→选择器 在特定服务器对此特征不关的情况下。

迈出人

如何更新

yum update lvemanager cagefs --enablerepo=cloudlinux-updates-testing

如何降级

yum downgrade lvemanager lve-utils cagefs cagefs-safebin alt-python27-cllib --enablerepo=cloudlinux-updates-testing
更改兴

Lve-Manager-6.0.6-1

  • Web-1799:添加能够为所有用户获取当前版本
  • Web-1776:管理员侧:重新设计PHP选择器接口
  • WEB-1783:实现逻辑禁用 领域 标签 for user
  • Web-1770:Admin Side:实现逻辑以使用PHP选择器选项卡中的域
  • Web-1775:admin侧:实现API以禁用PHP-FPM并为域设置系统版本
  • Web-1794:管理员侧:将Paginator添加到带有域的表格
  • Web-1629:如果值长,则不正确的PHP ERROR_REPORTing视图
  • WEB-1789:用户侧:确定所选的过滤器
  • WEB-1783:实现逻辑禁用 领域 用户标签 (part2)
  • Web-1788:Admin Side:如果Alt-PHP版本是系统默认值,则有关不可行的PHP选择器的消息
  • Web-1809:使用新的Paginator新设计
  • Web-1802:管理员侧:减少滤波器的数量 领域 tab
  • Web-1816:将RSS Feed的URL设置为 //blog.irobotmall.cn/tag/technical-blog/rss.xml
  • WEB-1793: Use the --style=user option when request user graphs
  • WEB-1803:管理方面:行为 领域 如果禁用CAGEFS,则选项卡
  • Web-1822:当禁用CageFS时显示不可用页面
  • Web-1823:PHP选择器小修复
  • WEB-1785:管理方: Dashboad. 警告PHP选择器问题
  • Web-1821:在“确认”窗口中显示正确的版本,用于激活PHP选择器
  • Lveman-1645 Cl-Quota不会清理旧用户
  • WEB-1279:显示CLDIAG的等待进展 选择器 tab

Llve-Utils-4.0.6-1

  • PTCLLIB-192:在Directadmin上实现基于文件夹的挂钩安装机制
  • LU-1654: Set the cloudlinux=yes parameter in the /usr/local/directadmin/custombuild/options.conf
  • Lu-1685:纠正CLDIAG帮助中的拼写错误
  • Web-1788:Admin Side:如果Alt-PHP版本是系统默认值,则有关不可行的PHP选择器的消息
  • LU-1686:添加CLDIAG CRON检查支持的指标
  • LU-1544:LVE限制不会重置为经销商创建的帐户的Directadmin中的签名包限制
  • LU-1677:在每日统计数据中添加服务器上的域和子域数的收集
  • LU-1691:修复LVE-UTILS性能回归
  • LU-1672:添加降调使用度量
  • WEB-1785:管理方: Dashboad. 警告PHP选择器问题
  • Web-1784:管理员侧:关于不兼容性的消息

LALT-PYTHON27-CLLIB-2.0.11-1

  • WEB-1783:实现逻辑禁用 领域 标签 for user
  • PTCLLIB-199: Investigate why pre_delete_hooks fails on cPanel
  • PTCLLIB-192:在Directadmin上实现基于文件夹的挂钩安装机制
  • Web-1823:PHP选择器小修复

lcagefs-7.0.4-1

  • PTCLLIB-199: Add debug check in the pre_delete hook
  • Web-1788:Admin Side:如果Alt-PHP版本是系统默认值,则有关不可行的PHP选择器的消息
  • CAG-1033:禁用CPanel,Directadmin等的不需要的CageFsctl呼叫
  • lu-1670:在挂钩中添加用于CageFSCTL呼叫的日志记录

新的PHP选择器接口 - 现在in Beta

 

b2ap3_large_php-selector-production-1

我们在LVE Manager V.6.0.6-1和其他新功能中为CPANEL引入了一种改进的PHP选择器接口。我将在下面展示它们。

如何通过ClowLinux PHP选择器管理CPANEL MultiPHP Manager管理到管理

CPanel有自己的MultiPHP管理器来管理域的PHP版本。要移动域通过MultiPHP Manager管理到由CloudLinux PHP选择器管理,需要满足特定条件:

  1. 应安装以下组件:
  2. 系统PHP版本不是 ALT-PHP. (它应该是 EA-PHP.)
    你可以检查一下 CPANEL管理界面→MultiPHP Manager→PHP版本
    MultiphpManager.
  3. 选择适用的PHP处理程序,用于PHP版本,它是系统版本。 PHP选择器是 兼容的 具有以下技术: suphp,mod_fcgid,cgi(suexec),litespeed。您可以检查使用的处理程序 CPANEL管理界面→MultiPHP Manager→PHP处理程序

    PHP.处理程序
  4. 域没有 PHP.-FPM. 启用。你可以检查是否 PHP.-FPM. 已启用\已禁用 CPANEL管理接口→MultiPHP Manager→PHP版本→ 滚动到 设置每个域的PHP版本
  5. 域的PHP版本等于系统PHP版本。您可以检查PHP版本 CPANEL管理接口→MultiPHP Manager→PHP版本→ 滚动到 设置每个域的PHP版本
  6. CloudLinux PHP选择器中的PHP版本不等于本机PHP版本。你可以检查一下 CPANEL用户界面→ 选择 PHP版本→ 选择不等于本土的PHP版本点击 Set as current.

仪表板通知 

我们处理最受欢迎的问题并向您添加他们的通知 仪表板 (admin interface).

仪表板Notifications.

 

诊断工具

在这一点 选择器 选项卡(管理员接口)我们有改进了我们的诊断工具。

诊断工具

此工具可以处理哪些问题:

  1. mod_suexec.. is not installed
  2. ALT-PHP. 版本是系统默认版本
  3. 有些用户域有 PHP.-FPM. 启用或PHP版本与系统默认版本不同

如果问题已修复,您可以刷新诊断。

PHP.选择器选项卡(管理界面)

在里面 选择器 选项卡,我们添加了一个子标签 Domains 所有 用户域 pairs.

domainssubtab1.

当管理员点击时 使用PHP选择器, PHP.-FPM. 已被设置为OFF,PHP版本设置为系统默认版本。用户的域获取PHP选择器的用户界面中选择的PHP版本。

PHP.选择器选项卡(最终用户界面)

域名 选项卡也可在PHP选择器最终用户界面中使用。

domainsui1.

 

如果管理员已成功执行步骤一到四个 如何切换 部分,那么最终用户可以配置域以使用CloudLinux PHP选择器。

最终用户应该执行以下操作:

  1. 点击 使用PHP选择器

    umerphpselector1-1

  2. 在PHP选择器中设置版本

    setversion.

如果 PHP.-FPM. 已为域启用(请参阅第四步 如何切换 部分)唯一的管理员可以将其设置为 禁用.

管理员可以禁用 我的领域 子标签中 管理员界面→LVE Manager→选择器 在特定服务器对此特征不关的情况下。

迈出人

如何更新

yum update lvemanager cagefs --enablerepo=cloudlinux-updates-testing

如何降级

yum downgrade lvemanager lve-utils cagefs cagefs-safebin alt-python27-cllib --enablerepo=cloudlinux-updates-testing
更改兴

Lve-Manager-6.0.6-1

  • Web-1799:添加能够为所有用户获取当前版本
  • Web-1776:管理员侧:重新设计PHP选择器接口
  • WEB-1783:实现逻辑禁用 领域 标签 for user
  • Web-1770:Admin Side:实现逻辑以使用PHP选择器选项卡中的域
  • Web-1775:admin侧:实现API以禁用PHP-FPM并为域设置系统版本
  • Web-1794:管理员侧:将Paginator添加到带有域的表格
  • Web-1629:如果值长,则不正确的PHP ERROR_REPORTing视图
  • WEB-1789:用户侧:确定所选的过滤器
  • WEB-1783:实现逻辑禁用 领域 用户标签 (part2)
  • Web-1788:Admin Side:如果Alt-PHP版本是系统默认值,则有关不可行的PHP选择器的消息
  • Web-1809:使用新的Paginator新设计
  • Web-1802:管理员侧:减少滤波器的数量 领域 tab
  • Web-1816:将RSS Feed的URL设置为 //blog.irobotmall.cn/tag/technical-blog/rss.xml
  • WEB-1793: Use the --style=user option when request user graphs
  • WEB-1803:管理方面:行为 领域 如果禁用CAGEFS,则选项卡
  • Web-1822:当禁用CageFS时显示不可用页面
  • Web-1823:PHP选择器小修复
  • WEB-1785:管理方: Dashboad. 警告PHP选择器问题
  • Web-1821:在“确认”窗口中显示正确的版本,用于激活PHP选择器
  • Lveman-1645 Cl-Quota不会清理旧用户
  • WEB-1279:显示CLDIAG的等待进展 选择器 tab

Llve-Utils-4.0.6-1

  • PTCLLIB-192:在Directadmin上实现基于文件夹的挂钩安装机制
  • LU-1654: Set the cloudlinux=yes parameter in the /usr/local/directadmin/custombuild/options.conf
  • Lu-1685:纠正CLDIAG帮助中的拼写错误
  • Web-1788:Admin Side:如果Alt-PHP版本是系统默认值,则有关不可行的PHP选择器的消息
  • LU-1686:添加CLDIAG CRON检查支持的指标
  • LU-1544:LVE限制不会重置为经销商创建的帐户的Directadmin中的签名包限制
  • LU-1677:在每日统计数据中添加服务器上的域和子域数的收集
  • LU-1691:修复LVE-UTILS性能回归
  • LU-1672:添加降调使用度量
  • WEB-1785:管理方: Dashboad. 警告PHP选择器问题
  • Web-1784:管理员侧:关于不兼容性的消息

LALT-PYTHON27-CLLIB-2.0.11-1

  • WEB-1783:实现逻辑禁用 领域 标签 for user
  • PTCLLIB-199: Investigate why pre_delete_hooks fails on cPanel
  • PTCLLIB-192:在Directadmin上实现基于文件夹的挂钩安装机制
  • Web-1823:PHP选择器小修复

lcagefs-7.0.4-1

  • PTCLLIB-199: Add debug check in the pre_delete hook
  • Web-1788:Admin Side:如果Alt-PHP版本是系统默认值,则有关不可行的PHP选择器的消息
  • CAG-1033:禁用CPanel,Directadmin等的不需要的CageFsctl呼叫
  • lu-1670:在挂钩中添加用于CageFSCTL呼叫的日志记录

订阅CloudLinux时事通讯